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C# DASTURLASH TILIDA MVC 4 TEXNOLOGIYASIDAN FOYDALANIB 

WEB SAHIFA TAYYORLASH BOSQICHLARI. 
 

        Ziyomat SHIRINOV 

Buxoro davlat universiteti  

axborot texnologiyalar kafedrasi 

 

Maqolada C# dasturlash tilida MVC texnologiyasini qo‘llagan holda web sahifa tayyorlash haqida 

so‘z yuritiladi. Bu yerda C# ni endi o‘rganayotgan, ma’lumotlar bazasi va web dasturlashdan xabardor 

boshlagan dasturchilar uchun MVC(Model View Controller) dan foydalanib web sahifa tayyorlashda duch 

kelishlari mumkin bo‘lgan bazi kamchilarga e’tibor qaratilgan. 

Tayanch so‘zlar: dasturlash, ma’lumot, jadval, ko‘rinish(view), model, kontroller, sahifa, obyekt,  

Entity Framework, C#, loyiha, metod, xususiyat,  brauzer, murojaat. 

В этой статье описывается, как создать веб-страницу с использованием технологии MVC на 

языке программирования C#. Для разработчиков, которые уже изучают C# и знакомы с базой данных 

и веб-программированием, рассмотрим некоторые из недостатков, с которыми они могут 

столкнуться при разработке веб-страницы с использованием MVC (Model View Controller). 

Ключевые слова: программирование, данные, таблица, представление, модель, контроллер, 

страница, объект, Entity Framework, C #, проект, метод, свойство, браузер, ссылка. 

This article describes how to create a web page using MVC technology in the C # programming 

language. For developers who already learn C # and are familiar with the database and web programming, 

consider some of the disadvantages that they may encounter when designing a web page using MVC (Model 

View Controller). 

Key words: programming, data, table, view, model, controller, page, object, Entity Framework, C #, 

project, method, property, browser, reference. 

 

Hozirgi vaqtda barcha korxona va tashkilotlar o‘zlarining web sahifalariga ega va yangi tashkil 

qilinayotganlarida bu bir vazifa hisoblanadi. Web sahifa tayyorlashda asosiy hisoblanuvchi ma’lumotlar doimo 

o‘zgarib boradi. Bu o‘zgarishlarni doimiy aks ettirib borishda doimo biror bir dashqi manbada ma’lumotlarni 

saqlashga to‘g‘ri keladi. Har bir dasturchi buni o‘ziga xos tarzda amalga oshiradi. Hozirda bir qancha 

zamonaviy texnologiyalar mavjud bo‘lsada, bizdagi namunaviy dasturlarimizda C# dasturlash tili va SQL 

Server ma’lumotlar bazasini boshqarish tizimlarida ishlashga e’tibor qaratilgan. Ushbu maqola ham talabalar 

bilimini baholash uchun mo‘ljallab tuzilishi kerak bo‘lgan web sahifaning ma’lumotlarini saqlash jaroyonini 

qanday amalga oshirish mumkinligini ko‘rsatib o‘tmoqchimiz. 

Masalaning umumiy ko‘rinishi quyidagicha:   

 
Endi Visual Studio 2012 bu jarayon qanday bo‘lishini ko‘rib o‘tsak. 

Visual Studio 2012 da loyiha yaratish quyidagicha amalga oshiriladi: 

1. Visual Studio 2012 muhiti ishga tushiriladi. 

2. File->New->Project tanlaniladi. [1.B.10] 
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3. Hosil bo‘lgan oynadan Installed->Visual C#->Web->ASP.NET MVC 4 Web Aplication 

tanlaniladi va Name qatorida bo‘lajak loyihaning nomi kiritilib OK tugmasi bosiladi. [3.B.108] 

 
4. Keyingi oynada Select a template bo‘limidan Empty bo‘limini tanlab OK tugmasi bosiladi. 

Shundan so‘ng bizga yangi bo‘sh loyiha yaratiladi. Endi uni o‘zi bu loyihani o‘zimiz 

xohlaganimizdek tayyorlab olishimiz mumkin. 

MVC texnologiyasida birinchi navbatda loyihaning modeli tayyorlanadi. Bu jarayon MasalaNom va 

MasalaTayyor jadvallari uchun ko‘rib chiqaylik. 

MasalaNom jadvalidagi ma’lumotlarni saqlash uchun model yozish quyidagi tartibda amalga 

oshiriladi. 

Solution Explorer bo‘limidan Models papkasi ustida sichqonchaning o‘ng tugmasi bosiladi va 

ro‘yxatdan Add->New Item… tanlaniladi. [1.B.40], [4.B.126]

 
Hosil bo‘lgan oynadan esa Installed->Visual C#->Code dan Class tanlaniladi va Name qatorida 

model nomi ko‘rsatilib Add tugmasi bosiladi. 
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Shundan so‘ng bizga yangi MasalaNom nomli sinf hosilqilinadi va biz yuqoridagi jadval 

maydonlarni ifodalovchi xususiyatlarni kiritib olamiz 

public class MasalaNom{ 

        public int masalaNomId { get; set; } 

        public string nomi { get; set; } 

        public virtual ICollection<MasalaTayyor> MasalaTayyorTuplam { get; set; } 

    }  

Yuqorida jadvalning ikkitamaydoni uchun uchun ikkita xususiyat va bitta jadvallar orasidagi 

bog‘lanishni hosil qilish uchun maxsus to‘plam xususiyati hosil qilingan. [1.B.42] 

Yuqoridagi ketma-ketlikni MasalaTayyor jadvali uchun ham bajarsak, uning sinfi quyidagicha 

bo‘ladi: 

        public class MasalaTayyor{ 

            public int masalaTayyorId { get; set; } 

            public int MasalaNomId { get; set; } 

            public MasalaNom MasalaNomJoriy { get; set; } 

            public int MasalaId { get; set; } 

            public string berilganJavob { get; set; } 

        } 

Endi loyihamizda EntityFrameworkdan foydalanish uchun quyidagi ketma-ketlikni bajaramiz: 

Loyihamizga Entity Framework 6.2.0.0 ni bog‘lab qo‘yish uchun menyular qatoridanb Tools -> 

Library Package Manager tanlaniladi va Package Manager Console ustida sichqonchaning chap tugmasi 

bosiladi. 
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Shundan so‘ng muhit oynasining ostgi qismida quyidagi ko‘rinish hosil bo‘ladi. 

 
Endi Entity Framework 6.2 o‘rnatish uchun quyidagi buyruqni yozishingiz kerak 

PM> Install-Package EntityFramework -version 6.2.0.0 

Buyruq yozilgach klaviaturadan enter tugasi bosiladi. Yana bir muhum ma’lumot Entity Framework 

o‘rnatish jarayonida kompyuteringiz internetga ulangan bo‘lishi lozim. Bir necha sekundlardan so‘ng siz 

Visual Studio 2012 dagi loyihangizga EntityFramework 6.2 yuklanib o‘rnatilganligi haqidagi tasdiqlash 

ma’lumotlarni ko‘rasiz. [2.B.42] 

 
U web.config fayliga biro z o‘zgartirish kiritadi, uni solution explorer oynasidan topishingiz 

mumkin. [2.B.47] 

 
Agar bizda oldin biror loyihamizga EntityFramework yuklangan bo‘lsa u holda bizga internet 

mavjud bo‘lmaganda ham EntityFramework qo‘shish imkoni bo‘ladi bu esa quyidagicha bajariladi: 

Solution Explorer bo‘limidan loyiha nomi ustida sichqonchaning o‘ng tugmasi bosiladi va 

ro‘yxatdan Manage NuGet Packages… tanlaniladi va hosil bo‘lgan oynadan Recent packages… bo‘limi 

talanilib  EntityFramework qatori topiladi va u yerdagi Install tugmasi bosiladi. 
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Shundan so‘ng biz DbContext sinfiga merosxo‘r qilib bitta sinf yaratamiz. 

Sinfni qo‘shish tartibi 

Models papkasi ustida sichqonchaning o‘ng tugmasini bosamiz, u solution explorer oynasida 

mavjud, Add ->New Item… bosamiz va hosil bo‘lgan muloqot oynasida sinfimiz nomini NazoratContext 

deb nomlaymiz. 

 
Sinfni yaratgach nomlar fazosi deb ataluvchi qotorlar davomida quyidagi qatorni qo‘shib qo‘yamiz: 

using System.Data.Entity; 

Keyin sinfning tuzulishini quyidagicha shakllantiramiz. 

public class NazoratContext : DbContext{ 

        public DbSet<MasalaNom> MasalaNomTuplam { get; set; } 

        public DbSet<MasalaTayyor> MasalaTayyorTuplam { get; set; } 

    } 

Yuqoridagi amallarni bajargandan so‘ng solution explorer dan web.config file faylini oching 

connection string nomli qatorga ConfigSections tag(teg) ni qo‘shib qo‘ying. [1.B.43] Tegni configSection 

tegi yakunlangandan so‘ng qo‘shish zarur. Bu tegning ko‘rinishi quyidagicha: 

<connectionStrings>  

<add name="NazoratContext" connectionString="Data  Source=DOTNET-PC\MSSQLSERVER2K8;Initial 

Catalog=Nazorat; User ID=sa; Password=1234" providerName="System.Data.SqlClient"/>  

</connectionStrings> 

Siz yuqorida berilgan qatorlardan Data  Source ning qiymatini o‘zingizning kompyuteringizning 

nomiga moslaysiz. SQL server ochib u yerdan ID=sa va password ni 1234 Sizning kompyuteringizdagi bilan 

bir xil qilib qo‘yishingiz kerak. Ma’lumotlarni kiritib bo‘lgach web.config quyidagi ko‘rinishda bo‘ladi: 
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Yuqoridagilarni bajarib bo‘lgach ma’lumotlar bazasini yaratish so‘rovini bajaramiz. [2.B.82] 

Ma’lumotlar bazasini bog‘lanishlar bilan yaratish. 

Jarayonni bajarish uchun menyular qatoridan Tools -> Library Package Manager va ro‘yxatdan 

Package Manager Console bo‘limi ustida sichqonchaning chap tugmasi bosiladi. Uning Visual Studio 

2012 dagi ko‘rinishi quyidagicha: 

 
Buyruq qatorini quyidagicha yozib enter tugmasini bosamiz: 

PM> Enable-Migrations 

Buyruq bajarilganligini tasdiqlovchi quyidagi ma’lumotlarni olamiz: 

 
Bu jarayon bajarilgach solution explorer yana bir Migrations nomli papka hosil bo‘ladi va unda 

Configurations.cs nomli fayl qo‘shib qo‘yilgan bo‘ladi. 
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Configurations.cs faylining ko‘rinishi quyidagicha bo‘ladi: 

 
Keying qadamda siz Configuration metodi ichidagi AutomaticMigrationsEnabled ning qiymatini true 

ga o‘zgartirib qo‘yishingiz talab qilinadi. Bu esa keyinchalik sizga bazada qo‘shimchalar qilish imkonini 

beradi. 

public Configuration(){ 

            AutomaticMigrationsEnabled = true; 

        } 

Ma’lumotlar bazasini yaratish uchun quyidagi buyruqni gajarishingiz kerak: 

PM> Update-Database 

 
Bu sizga SQL server da ma’lumotlar bazasi yaratilganligini tasdiqlaydi: 

 
Kontrollerlar(Controllers) va ko‘rinishlar yaratish(Views) 

MasalaNom jadvaliga ma’lumot kiritish va unda bor ma’lumotlarni chiqarish uchun kontrollar 

yaratish yaratish quyidagicha bo‘ladi: 

Solution Explorer bo‘limidan Controllers papkasi ustida sichqonchaning o‘ng tugmasi bosiladi va 

ro‘yxatdan Add->Controller… tanlanilib Add tugmasi bosiladi. [1.B.17], [2.B.113] 
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Kontroller yaratish oynasi ochilganda u yerdagi kontrollerga nom berish qatorida nom kiritilayotgan 

vaqtda Controller so‘zini oxirida saqlab qolish kerak. Bu kontroller yaratishdagi oldindan kelishilgan qoida 

hisoblanadi.  

 
Index metodi barcha kontrollerlar uchun bosh sahifani ifodalovchi sahifaga o‘tishni taminlab beradi. 

Bu metodda MasalaNom jadvalidagi ma’lumotlarni chiqaruvchi sifatida aniqlab uning sahifasi uchun 

(ko‘rinish)view yarataylik. [4.B.134] 

Buning uchun Index metodi nomi ustida sichqonchaning o‘ng tugmasi bosiladi va ro‘yxatdan Add 

View… bandi tanlanadi. [1.B.23], [3.B.116] 
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Ko‘rinish qo‘shish oynasi Create a strongly-typed view bandiga belgi qo‘yamiz, Model class: 

bandidagi ro‘yxatdan MasalaNom (NazortSavollar.Models) ni tanlaymiz va Scaffold template: List bandini 

tanlab Add tugmasini bosamiz. 
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Yuqoridagi rasmda Index.cshtml faylining ko‘rinishi keltirilgan va bu yerda foreach qatoriga e’tibor 

beradigan bo‘lsak u yerda Model toplamining elementlariga murojaat mavjud. Shu sababdan biz yaratgan 

kontrollerdan uning ko‘rinishi(view)ga modelni argument sifatida yuborishimiz kerak. Index metodi 

ko‘rinishi quyidagicha bo‘ladi: 

using System; 

using System.Collections.Generic; 

using System.Linq; 

using System.Web; 

using System.Web.Mvc; 

using NazortSavollar.Models; 

namespace NazortSavollar.Controllers{ 

    public class MasalaNomController : Controller{ 

        NazoratContext ns = new NazoratContext(); 

        public ActionResult Index(){ 

            return View(ns.MasalaNomTuplam.ToList()); 

        }    } } 

Dasturni ishga tushirish uchun menyular qatorida Debug->Start Debugging tanlaniladi. Visual 

Studio IIS Express deb nomlanuvchi serverni ishga tushuradi va avtomatik brauzerlardan biri ishga tushib 

dasturni belgilangan manzil bo‘yicha yuklashga harakat qiladi. Bunda u birinchi navbatda kontroller 

yozishdagi kelishuvga asosan HomeController deb nomlanuvchi kontrollerning Index nomli metodini ishga 

tushurishga harakat qiladi. Biz bu kontrollerni yaratmaganimiz uchun quyidagi rasmda keltirilgan xatolikka 

duch kelamiz. 

 
Yuqoridagi rasmda keltirilgan brauzerning manzillar qatoridagi localhost:4854 qatoriga / belgisini 

qo‘shib undan so‘ng kantrollerimizning nomini yozib klaviaturadan enter tugmasini bosamiz. 

Eslatma: localhost:4854 qatoridagi 4854 raqamlar ketma-ketligi sizda boshqacha bo‘lishi mumkin. 

 
Biz bu jadvalda hechqanday ma’lumot saqlamaganligimiz uchun sahifada jadval ustunining nomidan 

boshqa hech narsa mavjud emas.  

Endi bu jadvalimizga ma’lumot yozish uchun controller yozaylik. MasalaNomController sinfida 

yangi Kiritish, QushishMasalaNom va Xato nomli metodlarini yaratamiz. 

        public ActionResult Kiritish() { 

            return View(); 

        } 

        [HttpPost] 

        public ActionResult QushishMasalaNom(MasalaNom model){ 

            if (ModelState.IsValid){ 

                ns.MasalaNomTuplam.Add(model); 

                ns.SaveChanges(); 

                return RedirectToAction("Index"); 

            } 
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            return RedirectToAction("Xato"); 

        } 

        public ActionResult Xato(){ 

            return View(); 

        } 

Yaratilgan sahifalarni birma-bir ko‘rish uchun Index nomli sahifani ishga tushuramiz keyin u yerdan 

Create New bandini tanlaymiz. Kiritish sahifasi ochilgach u yerdagi maydonni to‘ldirib Create tugmasini 

bosamiz va bizga MasalaNom jadvaliga qo‘shilgan ma’lumot namoyish etiladi. [3.B.120]  
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